fbpx

Month: December 2015

Disabling of SSLv3 and TLS on ZZ Servers Services January 8, 2016

With widespread and disastrous SSL/TLS vulnerabilities taking place such as POODLE and FREAK, SSL and early TLS versions are no longer considered strong cryptography and any web site that still uses them is insecure. For PCI Clients: According to the new rules in PCI DSS v3.1, companies have until June 30, 2016 to update to …

Disabling of SSLv3 and TLS on ZZ Servers Services January 8, 2016 Read More »

Thank you for your interest.  We'd love the opportunity to help you find the best payment processing plan for your business. We look forward to talking with you.

Currently Processing Credit Cards?

Please complete this form to have a specialist contact you.

We’d love to chat.

Looking to

Start a Project?

CONTACT US
Scroll to Top